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PREFACE

About this manual

This manual relates to the VM600 MPS2 Configuration Software, from Meggitt Sensing
Systems’ Vibro-Meter® product line. It explains how to install and begin using the software,
and provides instructions on configuring the system.

NOTE: This document should be read in conjunction with the following Meggitt Sensing
Systems (MSS) manuals:
• VM600 Machinery Protection System (MPS) hardware manual
• VM600 Networking manual.

For information on the VM600 MPS1 Configuration Software, refer to the VM600 MPS1
Configuration Software for Machinery Protection Systems software manual.

The VM600 MPSx software (that is, MPS1 and MPS2) includes context-sensitive offline help.
This means that the help is installed locally on the computer (when the software is installed)
and that the text that appears depends on which part of the software is being displayed at the
time.

About Meggitt, Meggitt Sensing Systems and Vibro-Meter

Headquartered in the UK, Meggitt PLC is a global engineering group specialising in extreme
environment components and smart sub-systems for aerospace, defence and energy
markets.

Meggitt Sensing Systems is the operating division of Meggitt specialising in sensing and
monitoring systems, which has operated through its antecedents since 1927 under the
names of ECET, Endevco, Ferroperm Piezoceramics, Lodge Ignition, Sensorex, Vibro-Meter
and Wilcoxon Research. Today, these operations are integrated under one strategic
business unit called Meggitt Sensing Systems, headquartered in Switzerland and providing
complete systems, using these renowned brands, from a single supply base.

The Meggitt Sensing Systems facility in Fribourg, Switzerland was formerly known as
Vibro-Meter SA, but is now Meggitt SA. This site produces a wide range of vibration and
dynamic pressure sensors capable of operation in extreme environments, leading-edge
microwave sensors, electronics monitoring systems and innovative software for aerospace
and land-based turbo-machinery. This includes the VM600 MPSx Configuration Software
(MPS2 software) produced for the Vibro-Meter product line.

Who should use this manual?

This manual is intended for operators of machinery protection systems using the VM600
MPS2 software.

NOTE: The architectural aspects of the MPS2 software (Database > View >
Architectural option) are described in VM600 MPS1 Configuration Software for
Machinery Protection Systems software manual.
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Applicability of this manual

NOTE: This manual applies to version 2.7.xxx of the VM600 MPS2 software. It reflects the
features available with version 2.7.xxx and may not be applicable to earlier or later
versions of the software.

Terminology

NOTE: The MPC4 machinery protection card is available in different versions, including a
standard version, a separate circuits version and a safety (SIL) version.

The MPC4 SIL (safety MPC4 card) was developed to permit a wider range of installation
options with a single VM600 rack, for example, condition monitoring in addition to machinery
protection. Accordingly, the MPC4 SIL does not have a VME bus interface and can only be
configured via a direct connection to the RS-232 connector on its front panel (even for a
“networked” VM600 rack), in order to reduce the possibility of corruption of its configuration.
In addition, the MPC4 SIL does not provide all of the signal processing capabilities of the
standard and the separate circuits versions of the MPC4. Refer to the MPC4 machinery
protection card data sheet and the VM600 Machinery Protection System (MPS) hardware
manual for further information.

NOTE: Previously, the VM600 MPSx software referred to all versions of the MPC4 card as
MPC4. Starting with VM600 MPSx software version 2.6, the VM600 MPSx
software makes a distinction between different versions of the MPC4 card by
referring to both the standard version and the separate circuits version of the
MPC4 card as an MPC4 and referring to the safety version of the MPC4 card as
an MPC4 SIL.

For example, when adding an MPC4 card to a VM600 rack configuration, the user must select
either:

• MPC4 – to add a standard or a separate circuits MPC4 card.

• MPC4 SIL – to add a safety MPC4 card.

This distinction continues throughout the VM600 MPSx software, where MPC4 cards are
listed as either MPC4 or MPC4 SIL.

In general, MPC4 is used in this manual to refer to all versions of the card. However, where
it is necessary to make a distinction, MPC4 is used to indicate both the standard and separate
circuits versions of the card and MPC4 SIL is used to indicate the safety version.

Related publications and documentation

Related documents from Meggitt Sensing Systems (MSS) are: 

• VM600 Machinery Protection System (MPS) hardware manual
(MSS document ref. MAMPS-HW/E).

• VM600 MPS1 Configuration Software for Machinery Protection Systems software
manual (MSS document ref. MAMPS1-SW/E).

• MPC4 machinery protection card data sheet
(MSS document ref. 268-021).

• AMC8 analog monitoring card data sheet
(MSS document ref. 268-041).
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Operators of networked VM600 MPSs should also refer to the following document:

• VM600 Networking manual
(MSS document ref. MAVM600-NET/E).

Operators of safety-related systems (SRSs) should also refer to the following document:

• VM600 Functional Safety manual
(MSS document ref. MAVM600-FS/E).

Release notes

Before using the MPS2 software, read the Release Notes provided with the MPS2 Software
Installation Kit. The release notes are contained in a file called ReleaseNotes.pdf on the
CD. The Release Notes contain information on:

• New features of the latest version

• Resolved problems, known issues and bug fixes

• Compatibility with earlier software versions.



viii VM600 MPS2 software manual MAMPS2-SW/E
Edition 8 - June 2015

THIS PAGE INTENTIONALLY LEFT BLANK



VM600 MPS2 software manual MAMPS2-SW/E ix
Edition 8 - June 2015

SAFETY

Symbols and styles used in this manual

The following symbols are used in this manual where appropriate:

NOTE: This is an example of the NOTE paragraph style. This draws the operator’s
attention to complementary information or advice relating to the subject being
treated.

The WARNING safety symbol

THIS INTRODUCES DIRECTIVES, PROCEDURES OR PRECAUTIONARY MEASURES WHICH
MUST BE EXECUTED OR FOLLOWED. FAILURE TO OBEY A WARNING CAN RESULT IN
INJURY TO THE OPERATOR OR THIRD PARTIES.

The CAUTION safety symbol

This draws the operator's attention to information, directives or procedures
which must be executed or followed. Failure to obey a caution can result in
damage to equipment.
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What is MPS2?

INTRODUCTION

1 INTRODUCTION

1.1 What is MPS2?

MPS2 is a configuration software package for VM600 machinery protection systems, from
Meggitt Sensing Systems’ Vibro-Meter® product line. It is used to configure VM600 MPS
hardware as well as to collect data for condition monitoring purposes.

1.2 Differences between the MPS1 and MPS2 software

MPS1

The VM600 MPS1 Configuration Software package (MPS1 software) was developed to
enable the complete configuration of a VM600 machinery protection system. It allows the
user to adapt the VM600 hardware to the types of transducer or conditioner being used, to
define the type of signal processing, to set alarm levels and to read the measured values.

The VM600 MPS1 software uses an “architectural” approach to configure a VM600 MPS. To
enable this configuration step, the operator must first define a configuration tree structure for
the VM600 MPS containing databases, racks and individual cards. The configuration tree
reflects the true hardware architecture of the VM600 MPS.

MPS2

The VM600 MPS2 Configuration Software package (MPS2 software) is intended mainly to be
used with condition monitoring solutions. However, it also contains all the functionality
provided by the VM600 MPS1 software. These functions are accessed either by clicking the
Architectural View button at the bottom left-hand corner on the main window of the VM600
MPS2 Configuration Editor (VM600 MPSx software), or by selecting the
View > Architectural option from the Database drop-down menu.

The additional condition monitoring features, which are available only in the VM600 MPS2
software, are accessed either by clicking the Logical View button at the bottom left-hand
corner of the main window (VM600 MPS2 Configuration Editor), or by selecting the
View > Logical option from the Database menu, as shown in Figure 1-1. The term “logical”
is used here because this feature of the VM600 MPS2 software is used to sub-divide each
database logically into stations and machines. This structure does not necessarily reflect the
true architecture of the underlying VM600 MPS hardware.

Figure 1-1: Selection of the Architectural View or Logical View
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Offline help

INTRODUCTION

The Architectural View / Logical View button bar enables you to switch quickly between the
two views, and is shown below in Figure 1-2.

1.3 Offline help

The VM600 MPSx software (MPS2) includes offline help that is installed locally on the
computer. This help provides text that relate to windows within the software. You can obtain
a help topic window by clicking the Help button on the splash screen, as shown in Figure 1-3,
or by pressing the F1 key at any time while using the software.

Choose the Show Index button on the Help Topic window to obtain a list of topics (the Help
Index window appears).

You can also access the Help Index window by choosing Contents from the Help drop-down
menu, as shown in Figure 1-4.

1.4 Tool tips

The software also includes tool tips which help the user when entering values in some fields.
If the user enters an invalid value in a field, a tool tip appears giving the range of accepted
values.

Figure 1-2: Architectural View / Logical View button bar

Figure 1-3: Help button on the splash screen

Figure 1-4: Help drop-down menu
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Before starting

INSTALLING THE SOFTWARE

2 INSTALLING THE SOFTWARE

2.1 Before starting

2.1.1 Items delivered

For first-time installation, you should have received the following items:

• One CD containing:

• VM600 MPS2 Configuration Software

• An electronic version of the software manual (.pdf file):
VM600 MPS2 Configuration Software for Machinery Protection Systems
(MSS document ref. MAMPS2-SW/E)

• Release and Installation Notes (.doc file)

• One paper copy of the software manual:
VM600 MPS2 Configuration Software for Machinery Protection Systems
(MSS document ref. MAMPS2-SW/E)

• One RS-232 communication cable.

For a software update, you receive only the following item:

• One CD containing:

• VM600 MPS2 Configuration Software

• An electronic version of the software manual (.pdf file):
VM600 MPS2 Configuration Software for Machinery Protection Systems
(MSS document ref. MAMPS2-SW/E)

• Release and Installation Notes (.pdf file).

NOTE: All original CDs should be stored in a safe place once the software installation has
been performed.

2.1.2 System requirements

The VM600 MPS2 software may be installed on most modern personal computers or laptops.
The following minimum computer configuration is required to run the software:

• Microsoft® Windows® Server 2003, Windows NT, Windows 2000, Windows XP,
Windows Vista or Windows 7 operating system

• 200 MHz 32-bit (x86) processor or equivalent

• 32 MB system memory (RAM)

• At least 200 MB of hard disk space

• 16-colour VGA display

• One 9-pin serial port (RS-232)

• Ethernet or Fast Ethernet network card (TCP/IP)

• CD/DVD drive

• Optional 100 GB (or larger) backup media.
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2.2 Installation procedure

NOTE: Save your work and exit (close) all applications before beginning the installation.

The procedure below is valid for first-time installation of the VM600 MPSx software as well
as for subsequent installation of software releases.

NOTE: It is essential that you remove any previous versions of the software before
installing the new version. See 2.3 Removing an old version of the software.
Removing a previous version of the software does not remove any user-defined
databases.

1- Insert the CD containing the VM600 MPS2 software in the CD/DVD drive of your
computer.

The installation process should start automatically. If this is the case, the VM600 MPS2
InstallShield Wizard starts (the initial window of which is shown in Figure 2-1). Go to
step 5.

If the process does not start automatically, go to step 2.

2- Choose Start > Run from the Windows task bar.

3- Use the Browse function to find the executable file setup.exe in the root directory of
the CD.

4- Double-click the setup.exe file to start the VM600 MPS2 InstallShield Wizard (see
Figure 2-1). 

5- Follow the instructions given by the wizard to install the software.

As part of the installation process, the wizard displays a Customer Information window
that, among other information, asks you to enter the Serial Number of your software.

Figure 2-1: Welcome window of the VM600 MPS2 InstallShield Wizard
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If you accept the default Serial Number (BASIC MPS), the VM600 MPSx software licence
is not validated and a demonstration version of the software will be installed (see
Figure 2-2). This may consist of a limited set of features.

The CD Key, which is found on the back of the product CD case, must be entered as the
Serial Number (see Figure 2-3). This is necessary to validate the VM600 MPSx software
licence and unlock the functionality offered by VM600 MPS2, that is, VM600 trending
operations.

Figure 2-2: Customer Information window showing the default Serial Number

Figure 2-3: Customer Information window showing an example valid Serial Number 
(CD Key)
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NOTE: If a valid CD Key to activate the VM600 MPS2 software is not entered, the software
is limited to the free-of-charge VM600 MPS1 functionality.

6- Define the location where the software is to be installed on the hard disk. The following
default destination folder is proposed:

C:\Program Files\VM600_MPS

An alternative folder can be chosen if desired.

NOTE: The default location for the Windows Program Files folder depends on the
operating system installed on the computer:
C:\Program Files on 32-bit versions of Windows, but
C:\Program Files (x86) on 64-bit versions of Windows.

A VM600 MPS2 icon  (shortcut) appears on the Windows desktop when the
installation is complete.

2.3 Removing an old version of the software

NOTE: Save your work and exit (close) all applications before removing an old version of
the software.

2.3.1 Precautions concerning databases

NOTE: Removing a previous version of the software does not remove any user-defined
databases. 
However, as an extra precaution, it is recommended to make a backup copy of
your database(s) before removing any software.
This copy can later be removed after checking that the software upgrade has been
performed correctly.

Data is stored in database directories having a .db file name extension. Unless an alternative
destination folder was chosen, these directories are found in the following default folder:

C:\Program Files\VM600_MPS

NOTE: The default location for the Windows Program Files folder depends on the
operating system installed on the computer:
C:\Program Files on 32-bit versions of Windows, but
C:\Program Files (x86) on 64-bit versions of Windows.

You should make a (temporary) copy of these database directories elsewhere on your
computer. Do not put them under C:\Program Files\VM600_MPS.
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2.3.2 Removing the software

Use the procedure below to remove an old version of the software before installing a newer
version:

1- Choose Add or Remove Programs from the Windows Control Panel.

2- Select Change or Remove Programs.

3- Highlight the application (VM600 MPS software) and click the Remove button.
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3 GETTING STARTED

3.1 Starting the VM600 MPS2 software

To start the VM600 MPS2 software:

1- Double-click the MPS2 icon  on your desktop.

This icon was created during the installation of the software. If for some reason it does
not appear on the desktop, click Start > Programs > VM600 MPS Software > MPS2, or
navigate to the VM600_MPS\Bin directory on the computer’s hard disk and double-click
the mps2.exe file.

The VM600 MPS2 splash screen (window) appears, as shown in Figure 3.1.

2- Choose the working language from the drop-down menu in the top, left-hand corner of
the window, as shown in Figure 3-2. The selected language is used by default the next
time the VM600 MPS2 software is started: 

Figure 3-1: VM600 MPS2 splash screen

Figure 3-2: Language drop-down menu
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3- Click the Begin button, which is found below the Language menu.

The main VM600 MPS2 Configuration Editor window appears, as shown in Figure 3-3: 

3.2 VM600 MPSx software privilege levels

As shown in Figure 3-4, the VM600 MPSx software implements a system of privileges (user
access rights) to control and limit the functionality of the software available to different levels
of user.

The VM600 MPSx software has four levels of privilege: Read, User, Master and Super. The
User, Master and Super levels are password protected in order to help prevent accidental
changes or unauthorised access to the configuration of a VM600 MPS.

The VM600 MPSx software privileges levels are described in detail in the VM600 MPS1
Configuration Software for Machinery Protection Systems software manual.

Figure 3-3: Main window of the VM600 MPS2 Configuration Editor
(VM600 MPSx software)

Figure 3-4: VM600 MPSx software privilege levels

VM600 MPSx software 
privilege levels

VM600 MPS
configuration
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In addition to the VM600 MPSx software’s system of privileges, a VM600 MPS containing a
CPUM card can implement additional rack security features (see 3.3 VM600 MPS rack
(CPUM) security).

3.3 VM600 MPS rack (CPUM) security

As shown in Figure 3-5, a VM600 MPS in a 19″ system rack (ABE04x) containing a CPUM
card can implement specific rack security features in order to limit the functionality of the MPS
that are available via the CPUM to Ethernet-based connections, such as the VM600 MPSx
software, the CPUM Configurator software or a Modbus TCP connection.

NOTE: See 3.4 CPUM Configurator software for further information on the
CPUM Configurator software.

The use of the CPUM security features (CPUM access lock and MPS password validation)
is recommended in order to help prevent accidental or unauthorised access to a VM600 MPS
configuration and other MPS system functionality, thereby reducing the possibility of
interference in the operation of the MPS and the machinery being monitored.

MPS rack (CPUM) security is described in detail in the VM600 MPS1 Configuration Software
for Machinery Protection Systems software manual.

The VM600 MPS rack (CPUM) security features are in addition to the VM600 MPSx
software’s system of privileges (see 3.2 VM600 MPSx software privilege levels).

Figure 3-5: VM600 MPS rack (CPUM) security

VM600 MPSx software 
privilege levels

CPUM access

CPUM password
validation

VM600 MPS
configuration
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3.4 CPUM Configurator software

CPUM Configurator is a program that communicates with a CPUM card in a VM600 rack over
an Ethernet (TCP/IP) link. Basically, it provides a graphical user interface for a Telnet session
between a CPUM Configurator (Telnet client) and a CPUM card (Telnet server), and is used
primarily for configuring and managing CPUM cards / VM600 racks

NOTE: Refer to the VM600 Networking manual for further information on the
CPUM Configurator software.
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4 USING VM600 MPS2 FOR CONDITION MONITORING

4.1 Introduction

This section explains how to configure the VM600 MPS2 software to perform conditioning
monitoring.

It is assumed in this section, and everywhere else in this manual, that the “architectural”
structure of the database(s) has already been created. This will have been done using either
of the following:

• The VM600 MPS1 software.

• The VM600 MPS2 software with the View > Architectural option chosen from the
Database drop-down menu.

NOTE: The architectural aspects of the VM600 MPS1 software are fully described in the
VM600 MPS1 Configuration Software for Machinery Protection Systems software
manual.

4.1.1 Configuration trees (Architectural and Logical)

It is essential to create an architectural configuration tree structure to define the VM600 MPS
hardware architecture. The following steps enable you to do this:

1- Choose the View > Architectural option from the Database drop-down menu, or click
the button in the bottom left-hand corner of the window.

This tree has a structure and hierarchy similar to that shown in Figure 4-1 (a). In this
example there are n databases.

2- Attribute the VM600 racks used in the protection system to the various databases as
required. 

3- Define the cards (MPC4, MPC4 SIL, AMC8 and so on) used in each VM600 rack, along
with the slot position they occupy. 

4- Configure the inputs and outputs of the individual cards

5- Build the logical configuration tree structure by selecting the View > Logical option from
the Database drop-down menu, or click the button in the bottom left-hand corner of the
window.

The structure and hierarchy of this tree are shown in Figure 4-1 (b). 

NOTE: The number of databases will be the same as those defined in the architectural
configuration tree (n in this example).

6- You can now attribute stations to each database. 

A station can correspond, for example, to a particular group of machines that are
monitored by the VM600 MPS.

7- Define the machines which make up each station.

4.1.2 Acquiring and storing data for trend analysis

When the logical structure of the VM600 MPS has been defined, the VM600 MPS2 software
can be configured to acquire and store measured values in the database(s). This data can be
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recalled later for trend analysis. Trend information obtained in this way provides a useful tool
to help perform predictive maintenance of the machine being monitored.

NOTE: See 6 Storing acquired values in the database for further information on acquiring
and storing data for subsequent trend analysis. 8 Displaying historical data
describes how to display trend data.

4.1.3 Real-time analysis

As well as providing trend information on stored values, the VM600 MPS2 software allows
real-time display and analysis of measured values. These values may be displayed in the
form of Bar Charts and Strip Charts. 

NOTE: See 7 Displaying data in real-time for further information on real-time display and
analysis of measured values.

Figure 4-1: Structure and hierarchy of Architectural and Logical configuration trees

Database 1 Database 1
Rack 1 Station 1

Card 1 Machine 1
Card 2 Machine 2
.... ....
Card q Machine v

Rack 2 Station 2
Card 1 Machine 1
Card 2 Machine 2
.... ....
Card r Machine w

... ...
Rack m Station s

Database 2 Database 2
Rack 1 Station 1
Rack 2 Station 2
... ...
Rack p Station t

.......... ... .......... ...
Database n Database n

(a) Architectural configuration tree (b) Logical configuration tree
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4.2 Creating the Logical configuration tree

This section describes how to create the logical configuration tree. This defines the overall
logical structure of the protection system, rather than the architectural structure which is
defined by the hardware.

4.2.1 Creating databases

A database (or several databases) will normally have already been created when the
architectural configuration tree was created. An additional database can nevertheless be
created when the View > Logical option is chosen from the Database drop-down menu.

To create a database:

1- Select New Database from the Database drop-down menu at the top of the main
window (VM600 MPS2 Configuration Editor).

A dialog box as shown in Figure 4-2 appears.

2- Enter a name for the database in the Tag field.

This name must be unique, that is, no two databases can have the same name.

Some descriptive text can be entered in the Description field to provide further
information. Any text entered is visible as a cue card when the mouse pointer is placed
on the icon in the configuration tree representing the database.

The Current Folder line displays the folder on the hard disk in which the database is
stored. Click Change Folder to store the database in a different folder:

Figure 4-3 shows the appearance of a configuration tree with two databases created.

Figure 4-2: New Database dialog box

Figure 4-3: Configuration tree showing two databases
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You can use Windows Explorer to look at the contents of the VM600 MPS2 directory on the
hard disk. By default, databases are stored in the \Configuration sub-directory and have
the .db file name extension, as shown in Figure 4-4.

4.2.2 Attributing a station to a database

You must attribute a station (a specific machine or group of machines) to a database. You
can do this in one of two ways.

1- Either:

a. Select the Logical View.

b. In the logical configuration tree, select the database that is to store the station’s data.

c. Select New Station from the Database drop-down menu. The New Station dialog
box appears (Figure 4-6).

or

a. Select the Logical View.

b. In the logical configuration tree, select the database that is to store the station’s data.

c. Right-click to obtain the menu shown in Figure 4-5, and choose the New Station
command.

Figure 4-4:  VM600 MPS2 software database directories viewed with Windows Explorer

Figure 4-5: Adding a station to a database
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The New Station dialog box appears (see Figure 4-6).

2- Enter a name for the station in the Tag field. 

This name must be unique: that is, no two stations in the system can have the same
name.

Some descriptive text can be entered in the Description field to provide further
information. This text is visible as a cue card when the mouse pointer is placed on the
icon in the configuration tree representing the station.

3- Click OK to close the dialog box.

4.2.3 Attributing machines to a station

To attribute machines to a station, first highlight the station name in the logical configuration
tree using the left mouse button. You can do this in one of two ways. 

1- Either:

• Select Add Machine to Station from the Database drop-down menu. 

The New Machine dialog box appears (see Figure 4-8).

or

• Right-click the rack to display the menu shown in Figure 4-7, and choose Add
Machine to Station.

The New Machine dialog box appears.

Figure 4-6: New Station dialog box

Figure 4-7: Adding a machine to a station

Figure 4-8: New Machine dialog box
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2- Enter a name for the machine in the Tag field. 

This name must be unique: that is, two or more machines cannot have the same name.

Some descriptive text can be entered in the Description field to provide further
information. This text is visible as a cue card when the mouse pointer is placed on the
icon in the configuration tree representing the station.

3- Click OK to close the dialog box.

Figure 4-9 shows a typical logical configuration tree once several machines and stations
have been assigned to databases. 

Figure 4-9: Logical configuration tree containing several stations and machines
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5 MANAGING DATABASES, STATIONS AND MACHINES

This chapter describes how to declare and configure:

• Databases

• Stations

• Machines.

5.1 Managing databases

If a database is selected from the logical configuration tree, the main window (VM600 MPS2
Configuration Editor) resembles that shown in Figure 5-1.

On the right-hand side of the window, two tabs are available:

• Selected by default, The General Info tab shows information about the currently
selected database:

• Tag
Allows the database name to be changed.

• Description
Optionally, some descriptive text can be entered here. This text is visible when the
mouse pointer is placed on the database icon in the configuration tree.

• The Event Info tab shows information about events (see 5.1.6 Managing events).

Figure 5-1: VM600 MPS2 Configuration Editor at database level
(General Info tab)

Database status flag
Red: no acquisition/storage 
currently taking place
Green: data currently being 
acquired and stored

Current privilege level Error messages
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5.1.1 Performing consistency checks

Consistency checks are used to check the validity of the files in the selected database.

To perform consistency checks, choose Database > Consistency Checks > Perform
Checks.

The VM600 MPS2 software also performs consistency checks automatically whenever:

• Optionally, starting the VM600 MPS2 software for the first time.

• Switching to the Super privilege level (see 3.2 VM600 MPSx software privilege levels).

• Closing (exiting) the Database Manager utility (see 5.1.5 Using the Database Manager).

• Switching between Logical and Architectural views (see 4.1.1 Configuration trees
(Architectural and Logical).

The Consistency Checks window is displayed, as shown in Figure 5-2.

Figure 5-2: Consistency Checks window displaying previous results

Back to display previous results

Forward to display next results

Save currently displayed results as an HTML file

Print currently displayed results
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The Consistency Checks window lists the results of a number of checks that the VM600
MPS2 software carries out on the current database:

• Verifying that read/write access is granted to all database files.

• Checking that the dbinfo.db file exists.

• Converting rack files created with previous versions of the VM600 MPSx software to the
latest version.

• Checking for file extension mismatches in early machine files.

• Searching for blank tags in MPC and AMC configurations.

• Checking for AMC Board Level information problems due to the incorrect initialisation of
remote source channels 1 and 2 (Remote Channel Source #1 and #2).

If any errors or inconsistencies are found, the VM600 MPS2 software can automatically
perform any database updates necessary. It is strongly recommended that you request

automatic updates. Click the icon on the toolbar of the Consistency Checks window to
perform automatic updates.

The results of previous consistency checks are stored in order to allow you to refer to them
subsequently. You can use the following commands on the Database > Consistency
Checks menu to manage the results of previous consistency checks:

• View Previous Results
Displays the last Consistency Check file(s) created for the current database. You can
step back through earlier files by clicking the ‘Back’ button on the toolbar (see
Figure 5-2).

Alternatively, you can click the and icons on toolbar of the Consistency Checks
window to display the previous and next set of results, respectively.

• Clear Previous Results
Deletes all Consistency Check files created for the current database.

Alternatively, click the icon on the Consistency Checks window to display the previous
results.

5.1.2 Managing database data

You can use the following commands on the Database menu to manage data: 

• Delete Data
Deletes all data from the selected database, but keeps the structure of the database.

• Delete All Stations
Deletes all defined stations from both the selected database and the hard disk. This
action requires confirmation.

• Refresh Data Files
Ensures that the data files are consistent with respect to the architectural information
contained in the database. 

• Database Manager
Lets you perform database file operations. See 5.1.5 Using the Database Manager for
descriptions of the available commands.

• Refresh Database Files
Updates the version information in the selected database to the latest release and
performs any necessary updates. If some information cannot be updated, a window is
displayed indicating which database files could not be updated (the most likely reason is
that the database file is open in another program and its read-only attribute is therefore
set).
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5.1.3 Obtaining privileges

The Privileges drop-down menu allows you to set the privilege levels and to change
passwords.

Privilege levels are described in detail in 3.2 VM600 MPSx software privilege levels.

5.1.4 Starting and stopping data acquisition

The start acquisition and stop acquisition buttons in the toolbar activate and
deactivate the acquisition and storage of data in the databases, respectively.

If several databases exist, you cannot selectively activate only one of them.

When data is being acquired and stored, the database status flag at the bottom of the window
(see Figure 5-1) is green. It becomes red when no acquisition and storage is taking place.

5.1.5 Using the Database Manager

The Database Manager allows you to manage the databases created to contain VM600 MPS
configuration data. 

To start the Database Manager, click Database > Database Manager when you are at
Database Level.

The window in Figure 5-3 opens, listing the databases and providing access to the database
operations available in the VM600 MPS2 software.

Figure 5-3: Database Manager window
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The VM600 MPS2 Database Manager provides the commands listed in Table 5-1.

5.1.6 Managing events

You can display information about the different classes (types) of events that occur and are
recorded in the database:

• Diagnostic events.

• Alarm events.

• Inhibit events.

• Sensor events.

NOTE: Each database used by the VM600 MPS software contains a circular buffer for the
storage of all events and event information.
This events buffer is limited to a maximum size of 1000 events, so the oldest
events are deleted in order to create space for the new events (when more than
1000 events have been generated by the machinery monitoring system for a
database).

5.1.6.1 Diagnostic events

Diagnostic events include:

• Start (time at which a series of acquisitions started).

• Stop (time at which a series of acquisitions ended).

• Configuration download.

• Configuration upload.

• Configuration modification.

Table 5-1: Database Manager commands

Command Description

Copy DB Creates a copy of the selected database and adds it to the active DB list.

Move DB Moves the selected database to another location on your file system, 
and keeps it in the active DB list.

Delete DB Deletes the selected database and all related files and removes it from 
the active DB list.

Details Shows a list of all files in the selected database, their content and 
version.

Help Displays the On-line Help information.

Search Searches the specified drive for a valid VM600 MPS database.

Disable All Disables all databases in the active DB list.

Enable All Enables all databases in the active DB list.

Save Saves changes in the active DB list (applies to enabled databases only).

Close Closes (exits) the Database Manager window.
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5.1.6.2 Alarm events

Alarm events are listed in chronological order. The exact date and time of the alarm are
indicated, as well as the following:

• The class of alarm, including:

• Normal
• A+ (Alert+)

• A− (Alert−)

• D+ (Danger+)

• D− (Danger−)

• OK.

• Station name (the name entered in the Tag field of the General Info tab at station level).

• Machine name (the name entered in the Tag field of the General Info tab at machine
level).

• Point name (with the Database > View > Architectural option chosen, this is the name
entered in the Tag field when the Processed Output \ General window is displayed for
Processing Channel n (see example in Figure 5-9).

5.1.6.3 Inhibit events

Inhibit events include:

• Inhibit On – generated when the channel inhibit function is activated for an input channel.

• Inhibit Off – generated when the channel inhibit function is de-activated for an input
channel.

NOTE: The MPS software packages and Modbus can be used to send channel inhibit
commands to individual input channels in order to temporarily bypass a sensor and
the processing associated with it.

5.1.6.4 Sensor events

Sensor events include:

• Sensor OK – generated when the DC voltage of a sensor goes inside the OK levels
configured for the sensor.

• Sensor Fail – generated when the DC voltage of a sensor goes outside the OK levels
configured for the sensor.

NOTE: The OK levels are defined using the Upper OK Level and the Lower OK Level for
an input channel in the Architectural View.

5.1.6.5 Accessing and displaying events

To access event information:

1- Select a database in the Logical view.

2- Click the Event Info tab in the right hand side of the main window (VM600 MPS2
Configuration Editor).
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The Event Info window is displayed, as shown in Figure 5-4.

You can choose to display diagnostic events and/or alarm events by selecting the
Diagnostics and Alarm check boxes under Filters.

To update the Event Info window at any time, click the Refresh button.

To remove events from the list, select one or more events then click Delete Selected Events.
You can use the following keyboard shortcuts to select multiple events:

• To select a continguous (adjacent) range of events, click the first event in the range, then
SHIFT+click the last event in the range.

• To select a non-contiguous (non-adjacent) range of events, CTRL+click the required
events in any order.

Figure 5-4: Event Info window at database level
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5.2 Managing stations

You manage stations by selecting a station in the logical configuration tree. The main window
(VM600 MPS2 Configuration Editor) resembles that shown in Figure 5-5.

On the right-hand side of the window, two tabs are available:

• Selected by default, The General Info tab shows information about the currently
selected station:

• Tag
Allows the station name to be changed.

• Description
Optionally, some descriptive text can be entered here. This text is visible when the
mouse pointer is placed on the station icon in the configuration tree.

• The Event Info tab shows information about events (see 5.1.6 Managing events). This
tab is very similar to the window displayed at database level (see Figure 5-4), but only
shows information concerning the selected station and the machines associated with it.

Figure 5-5: VM600 MPS2 Configuration Editor main window at station level
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5.3 Managing machines

When you select a machine in the logical configuration tree, the main window (VM600 MPS2
Configuration Editor) resembles that shown in Figure 5-6.

In addition to the General Info tab, you can access the Timing Info and Event Info windows
by clicking the tabs of the same names.

Figure 5-6: VM600 MPS2 Configuration Editor main window at machine level
(General Info tab)
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5.3.1 Configuring information at machine level

When you select a machine in the Logical view, the General Info tab appears by default. A
typical window is shown in Figure 5-7.

The following programmable fields are present:

• Tag
Allows the machine name to be changed.

• Description
Optionally, some descriptive text can be entered here. This text is visible when the
mouse pointer is placed on the machine icon in the configuration tree.

5.3.1.1 Enabling and disabling data collection

The Machine Data Collection area of the tab contains Enable and Disable radio buttons. If
you select Enable, data concerning the machine can be acquired and stored when the Start
button in the toolbar of the main window (VM600 MPS2 Configuration Editor) at database
level is selected. If you select Disable, no data will be acquired or stored for this particular
machine.

The Max Data Points field allows you to set the maximum number of data points that will be
stored per output when recording data. The data is stored in a cyclical buffer. When the
maximum number of data points have been recorded, the oldest point at the beginning of the
buffer are overwritten by the newest data recorded.

Figure 5-7: General Info tab
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5.3.1.2 Attaching and unattaching sensors

The Unattached Sensors column contains a list of all the input signals associated with the
machine. The entries in this list are generated by the sensor tags defined by the user during
the definition of the architectural structure of the VM600 MPS. Figure 5-8 shows the Sensor
Tag field.

The Attached Sensors column is used to determine the sensors that are used to acquire and
store data. You include an entry in this column by first selecting it in the Unattached Sensors
column and clicking the >> button. The associated output points then appear in the
Associated Outputs column. You can move the entry back to the Unattached Sensors
column by clicking the << button.

An entry can be removed from the Attached Sensors column by selecting it with the mouse
pointer, then clicking the << button to transfer it to the Unattached Sensors column. When
this is done, any associated output points appearing in the Associated Outputs column are
removed.

5.3.1.3 Associating sensors with outputs

The Associated Outputs column is generated automatically by the software when the user
creates a list of Attached Sensors. This column shows the tags defined by the user during
the definition of the architectural structure of the VM600 MPS. Figure 5-8 shows the Sensor
Tag field of a measurement channel in the Architectural view.

Figure 5-8: Sensor Tag field
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Figure 5-9 shows the corresponding value of a Tag field for a processing channel.

Figure 5-9: Tag field (on Processed Output tab)
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5.3.2 Configuring timing information

To configure timing information, select the Timing Info tab, as shown in Figure 5-10. 

This tab enables you to configure parameters for the rate of data acquisition and storage.
These parameters act on the signals appearing in the Attached Output Points column
(visible on the General Info and Timing Info tabs). You can define three different cases by
using the Normal Mode Resolution, Averaging Interval and Alarm Mode Resolution
parameters.

5.3.2.1 Normal Mode Resolution

The Normal Mode Resolution defines the acquisition rate in the absence of an alarm.
Choose a time unit (seconds, minutes or hours) and then a value between 1 and 60. To view
the resulting data, select the Display Trend Chart option from the Machine drop-down
menu. You can define the number of acquisitions that can be stored in the Trend database,
up to a maximum of 50,000. If, for example, the rate is set to 1 acquisition per minute, trend
data covering a period of up to approximately 34.7 days (50,000 minutes) can therefore be
displayed. See 5.3.1 Configuring information at machine level for details.

5.3.2.2 Averaging Interval parameter

The Averaging Interval parameter acts upon the Normal Mode Resolution value. It allows
a number of acquisitions in normal mode to be averaged and stored in a separate database

Figure 5-10: Timing Info tab
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(the number of averaging intervals can be set between 1 and 100). The data obtained in this
way can be displayed by selecting the Display Averages Trend Chart option from the
Machine drop-down menu. The advantage of this technique is that it allows smoothened
(because averaged) trend data to be obtained, and the period covered can be much longer. 

For example, if the Normal Mode Resolution is set to 1 acquisition per minute and the
Averaging Interval is set to 60, one averaged acquisition per hour will be stored in the
Averages Trend database. This database also has a capacity of 50,000 acquisitions. In the
present example, averaged trend data covering a period of up to approximately 5.7 years
(50,000 hours) can therefore be displayed

5.3.2.3 Alarm Mode Resolution parameter

The Alarm Mode Resolution parameter enables the user to define an alternative acquisition
and storage rate in the event of an alarm being detected (see Figure 5-11). This rate is
independent of the Normal Mode Resolution value. You choose a time unit (seconds,
minutes or hours) and then a value between 1 and 60. Data obtained in this way is stored in
the Trend database (see description of Normal Mode Resolution above). Data obtained in
alarm mode is not taken into account when averaged data is stored in the Averages Trend
database.

5.3.2.4 Dynamic alarm levels

The lower part of the tab (under Analog Mode Resolution) allows dynamic alarm levels to
be attributed to selected output points. This feature allows one acquisition to be made for all
attached output points if the level of a particular signal changes by a predefined amount
(either increasing or decreasing in value) since the last acquisition. In this case, an acquisition
is then made for all points in the Attached Output Points and Output Points (Percent)
columns of the Timing Info tab (Figure 5-10). This feature allows data to be obtained between
two successive (scheduled) normal mode acquisitions (see Figure 5-11).

The next acquisition on all attached output points is made either at the scheduled acquisition
time or, if the level of the signal changes again, by more than the dynamic limit that was set.

5.3.2.5 Output Points column

The Output Points (Percent) column is used to define the signals that have a dynamic alarm
level applied to them. You should first select the point in the Attached Output Points
column. Enter a percentage value (dynamic alarm limit) in the Percent Change field. The
selected point should then be transferred to the Output Points (Percent) column by clicking
the >> button. The percentage value then appears in brackets after the tag corresponding to
the output point. 

For example, in Figure 5-10 the signal having the tag BBAB10-1000Hz / 4.1 has had a
dynamic alarm level of 3% attributed to it. This means that if the value of this signal deviates
from the last acquired value by more than 3% of the full-scale deflection (FSD) value defined
for the signal, data for all attached output points will be acquired once (see Figure 5-11). The
FSD value is set up with View > Architectural chosen from the Database drop-down menu
and the Processed Outputs \ General window selected. The value is entered in the Full
Scale Deflection field (see Figure 5-9).

NOTE: The definition of a dynamic alarm level here does not modify the alarm levels set
up for machinery protection purposes, that is, the values set up when View >
Architectural was chosen from the Database drop-down menu remain
unchanged. The violation of a dynamic alarm will not trip the machine, unless the
(static) trip level is simultaneously exceeded. It will simply initiate one cycle of
acquisitions for the attached output points.
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5.3.3 Displaying event information at machine level

To display event information for a selected machine, click the Event Info tab. This tab is very
similar to the window obtained at database level (see Figure 5-4), but only shows information
concerning the selected machine.

Scheduled acquisitions
(Normal Mode Resolution)

 Signal A

Signal B

Signal C

Signal
level

Time

Alarm level of 
Signal A

x% of FSD

x% of FSD

x% of FSD

x% of FSD

Acquisitions due to
dynamic alarms

Acquisitions in
alarm mode

Figure 5-11: Scheduled acquisitions, acquisitions due to dynamic alarms and acquisitions 
in alarm mode

Key:

• = Acquisition
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6 STORING ACQUIRED VALUES IN THE DATABASE 

6.1 Introduction

This chapter describes how to use the VM600 MPS2 software to acquire and store data in a
database for subsequent trend analysis. The trend information obtained in this way provides
a useful tool for predictive maintenance of the machine being monitored.

6.2 Creating the Architectural and Logical configuration trees

See 4 Using VM600 MPS2 for condition monitoring for further information on the structure of
the two configuration trees.

The first step is to create the architectural configuration tree to define the VM600 MPS
hardware architecture. This defines a VM600 machinery protection system (MPS) in terms of
database, racks and cards.

NOTE: For details on how to create the architectural configuration tree, refer to the
VM600 MPS1 Configuration Software for Machinery Protection Systems software
manual.

The logical configuration tree can then be built up by selecting the View > Logical option from
the Database drop-down menu. This tree uses a hierarchy based on database, stations and
machines (see Figure 4-1).

The following procedure should be applied for each database in the logical configuration tree:

1- Attribute one or more stations to the database. A station is defined as being a group of
machines. 

See 4.2.2 Attributing a station to a database for further information.

2- Attribute one or more machines to each station.

See 4.2.3 Attributing machines to a station for further information.

6.3 Configuring machines

Repeat the following procedure for each machine in the Logical View:

1- Switch to the Super privilege level (see 3.2 VM600 MPSx software privilege levels).

2- In the Logical View, select the machine from which you want to obtain data.

The General Info tab appears in the main window (VM600 MPS2 Configuration Editor). 

See 5.3 Managing machines and 5.3.1 Configuring information at machine level. 

3- Select the corresponding sensor tag names from the Unattached Sensors column for
all signals you want to acquire and store in the database.

Use the >> button to move the sensors to the Attached Sensors column.

When this is done, the associated output points appear automatically in the Associated
Outputs column.

4- Select the Enable button in the Machine Data Collection area of the General Info tab
to enable data acquisition and storage for that particular machine.

If the Disable button is selected, no data acquisition and storage occurs for that
particular machine when the Start button is selected.

5- Select the Timing Info tab to set up timing parameters as necessary. See
5.3.2 Configuring timing information.
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6.4 Starting the acquisition and storage of data

To start the acquisition and storage of data:

1- When each machine covered by the database has been set up as described in
6.3 Configuring machines, select the database in the logical configuration tree.

2- Click the Start button on the toolbar of the main window (VM600 MPS2
Configuration Editor).

The database status flag at the bottom of the main window turns green to show that data
is being acquired and stored.

NOTE: Remember that no data is acquired for a specific machine if the Enable button
under Signal Origin on the General Info tab has not been selected. 

Data acquisition and storage continues until you click the Stop button in the toolbar of the
main window (VM600 MPS2 Configuration Editor). When you do this, the database status
flag at the bottom of the main window turns red to show that data is no longer being acquired
and stored. 

NOTE: Data acquisition and storage also end if the VM600 MPS2 software exited
(stopped). 

6.5 Modifying the Architectural structure of a VM600 MPS

If the architectural structure of a VM600 MPS needs to be modified (for example, to add new
cards, or to change the configuration of a card), you must first stop the acquisition and
storage of data:

1- Click the Stop button in the toolbar of the main window (VM600 MPS2 Configuration
Editor) at database level.

2- Select Database > View > Architectural.

3- Make the changes to the architectural structure. 

4- Select Database > View > Logical.

5- Redefine the logical structure of the VM600 MPS as necessary.

6- Click the Start button in the toolbar of the main window (VM600 MPS2 Configuration
Editor) at database level to restart data acquisition and storage.

If you attempt to change the architectural structure without first stopping data acquisition and
storage, all the fields are unavailable (greyed out) when the View > Architectural option is
chosen.

NOTE: For more information on modifying the architectural configuration, refer to the
VM600 MPS1 Configuration Software for Machinery Protection Systems software
manual.



VM600 MPS2 software manual MAMPS2-SW/E 7 - 1
Edition 8 - June 2015

Introduction

DISPLAYING DATA IN REAL-TIME

7 DISPLAYING DATA IN REAL-TIME

7.1 Introduction

This chapter describes how to display measurement data using the Live Bar Chart and Live
Strip Chart commands in the Machine drop-down menu (Figure 7-1). These commands
allow signal values to be displayed in real-time.

For information on displaying historical data (which has been previously acquired and stored
in a database), see 8 Displaying historical data.

7.2 Displaying bar charts

7.2.1 Overview

To display bar charts:

1- Select a machine from the logical configuration tree. The General Info tab appears in the
main window (VM600 MPS2 Configuration Editor). (See 5.3.1 Configuring information at
machine level.)

2- Select the Live Bar Chart command from the Machine drop-down menu. The Bar Chart
Point Selection window appears (see Figure 7-2). All output points for which data exists
are listed in the Associated Outputs column.

Figure 7-1: Machine drop-down menu

Figure 7-2: Bar Chart Point Selection window
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3- Select the points you want represented as a bar chart (select more than one using
SHIFT+click for continguous points or CTRL+click for non-continguous points), then
transfer them to the Display Points column using the > button. Alternatively, transfer all
points using the >> button. 

4- Click the Display button to obtain the Machine Outputs window (see Figure 7-3).

Up to eight bar charts may be simultaneously displayed on the Machine Outputs window. The
window can contain a number of sub-pages if a large number of bar charts have been
generated. Each page is capable of displaying up to eight bar charts: the first page is used to
display charts 1 to 8, the second page displays charts 9 to 16, and so on. You access the
pages by clicking the coloured squares at the bottom of the window (see Figure 7-3).

The squares at the bottom of the window are colour coded to provide information at a glance
concerning the alarm status of the bar charts (and signals) associated with each window. The
colour coding is as follows:

• Green : No alarm condition exists on any of the signals.

• Yellow : Alert condition exists on one or more of the signals.

• Red : Danger condition exists on one or more of the signals.

Green bar:
No alarm condition

(1) Button to view charts 9 to 16 on the screen.
(2) Alarm summary indicator for bar charts 9 to 16

(colour indicates worst case present among these eight).

(1) Button to view charts 1 to 8 on the screen.
(2) Alarm summary indicator for bar charts 1 to 8

(colour indicates worst case present among these eight).

Yellow bar:
Alert level exceeded

Figure 7-3: Typical bar chart display (Machine Outputs window)

Red bar:
Danger level exceeded
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The squares are coloured according to the worst case present on the corresponding page. If,
for example, the second square is red, there is at least one signal represented by bar charts
9 to 16: that is, in a Danger condition, and others on that page may also be in an Alert
condition.

7.2.2 Modifying the presentation of a bar chart

The presentation of individual bar charts can be altered to improve their readability. To do
this, first click the bar chart you want to modify. The Bar Chart Options dialog box appears
(see Figure 7-4).

7.2.2.1 Modifying the scaling of a bar chart

The sequence below shows how to rescale an individual bar graph: 

1- In the example shown in Figure 7-5, the original scaling of the chart for “RTD c” is
unsatisfactory as the scale is too condensed.

2- Click the bar chart (RTD c) to obtain the Bar Chart Options dialog box (see Figure 7-6).

Note that originally in this example the Bar Chart Maximum field was set to 240 and the
Bar Chart Minimum field to -240, as shown in Figure 7-4.

3- Select maximum and minimum values that are closer to the measurement range of
interest. For example, in Figure 7-6 the Bar Chart Maximum field has been set to 120
and the Bar Chart Minimum field to -40.

4- Click the Apply/OK button. The rescaled bar chart can be seen in Figure 7-7. To cancel
any changes you have made in the Bar Chart Options dialog, if you have not already
clicked OK, click the Reset button.

Figure 7-4: Bar Chart Options dialog box
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Figure 7-5: Bar chart “RTD c” before correction

Figure 7-6: Bar Chart Options dialog box for chart “RTD c”
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7.2.2.2 Bar Chart Start at 0

If you clear the Bar Chart Start at 0 box in the Bar Chart Options dialog box, the bar chart
starts at the Bar Chart Minimum value, and not at zero. See the example in Figure 7-8.

7.2.2.3 Show Limit Labels

If you clear the Show Limit Labels box in the Bar Chart Options dialog box, the Alert and
Danger thresholds are removed from the bar chart. The Bar Chart Maximum and Bar Chart
Minimum values are displayed. See the example in Figure 7-9.

Figure 7-7: Bar chart “RTD c” after correction
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Figure 7-8: Clearing the “Bar Chart Start at 0” box

Figure 7-9: Clearing the “Show Limit Labels” box
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7.2.3 Drop-down menu commands for bar charts

The Machine Outputs window for bar charts contains the two drop-down menus as shown in
Figure 7-10.

In the File drop-down menu, the Print command allows the currently displayed bar charts to
be printed.

In the Options drop-down menu, the Freeze command allows the currently displayed bar
charts to be frozen. If the Freeze command is selected (see Figure 7-10), then Freeze is
turned on and the currently displayed bar charts will not be updated. Select this command
again to clear the check mark and turn off Freeze.

7.3 Displaying strip charts

7.3.1 Overview

A strip chart resembles an oscilloscope trace. The VM600 MPS2 software enables up to 16
strip charts to be displayed on a single window. Additional charts can be displayed on
sub-pages.

To display strip charts:

1- Use the mouse pointer to select a machine from the logical configuration tree. The
General Info tab appears by default in the main window (VM600 MPS2 Configuration
Editor). (See 5.3.1 Configuring information at machine level.)

2- Select the Live Strip Chart command from the Machine drop-down menu. The Bar
Chart Point Selection window appears (Figure 7-2). All output points for which data exists
are listed in the Associated Outputs column.

3- Highlight with the mouse pointer the points you want represented as a strip chart (select
more than one using SHIFT+click for continguous points or CTRL+click for
non-continguous points), then transfer them to the Display Points column using the
> button. Alternatively, transfer all points using the >> button.

4- Click the Display button to obtain the Machine Outputs window. The charts are
immediately displayed in real time. An example is shown in Figure 7-11.

Drop-down menu commands allow charts to be printed, and data to be displayed in tabular
form. See 7.3.2 Drop-down menu commands for strip charts for a description of all the
commands.

The horizontal and vertical axes of the strip chart are set by default, but you can zoom to
areas of particular interest (you must freeze the display before doing this). This is described
in 7.3.3 Sizing, repositioning and zooming.

To use the cursor feature, click with the mouse pointer on the chart at the point of interest.
The Cursor Box window opens (see Figure 7-12). The title bar of this window shows the date
and time of the acquisition. The signal values at that moment in time are shown in the window,

Figure 7-10: Drop-down menus for bar charts (in Machine Outputs window)
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along with the measurement units, the rectifier function and the full-scale deflection (FSD)
value. The figure in the % Max column expresses the measured value as a percentage of the
FSD.

To define the period over which the chart is plotted, select the Realtime command from the
Setup drop-down menu. The Realtime Display Setup dialog box appears (Figure 7-13). Enter
an acquisition rate (minimum value 1 second) in the Scan Rate field. The overall duration of
the real-time acquisition should be defined by selecting the appropriate button under
Realtime Display Period (values from 1 minute to 1 hour can be selected).

When more than 16 strip charts are displayed, colour-coded squares at the bottom of the
window provide information at a glance concerning the alarm status of the charts (and
signals) associated with each window, as shown in Figure 7-11. The colour coding is as
follows:

• Green : No alarm condition exists on any of the signals.

• Yellow : Alert condition exists on one or more of the signals.

• Red : Danger condition exists on one or more of the signals.
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Figure 7-11: Typical strip chart display (Machine Outputs window)

Buttons only visible when more than 16 charts displayed

(1) Button to view charts 17 to 32 on the screen.
(2) Alarm summary indicator for charts 17 to 32.

(colour indicates worst case present among the 16)

(1) Button to view charts 1 to 16 on the screen.
(2) Alarm summary indicator for charts 1 to 16.

(colour indicates worst case present among the 16)
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Figure 7-12: Typical strip chart display with the Cursor Box window open

Figure 7-13: Realtime Display Setup dialog box



VM600 MPS2 software manual MAMPS2-SW/E 7 - 11
Edition 8 - June 2015

Displaying strip charts

DISPLAYING DATA IN REAL-TIME

7.3.2 Drop-down menu commands for strip charts

The Machine Outputs window for strip charts contains seven drop-down menus as shown in
Figure 7-14.

• To print the currently displayed strip charts, choose Print from the File menu. 

• To obtain a data summary for each curve displayed, choose Data from the Info menu.

A Data Summary window as shown in Figure 7-15 appears. The End Date and No. of
Points relate to the moment at which the data summary was requested, and do not
change over time. The strip charts, however, continue to evolve in real time in the
background. 

To display a data summary for another signal, simply click the name of the signal (for
example BBAB10-1000Hz_4) from the list of names appearing at the bottom of the
Machine Outputs window. 

• In the Setup drop-down menu, choose the Realtime command to display the Realtime
Display Setup dialog box (Figure 7-13). This enables you to define the duration (x-axis)
of the strip chart.

The Display command of the Setup drop-down menu is not operational for strip charts.

• You can present the strip charts displayed in the Machine Outputs window in tabular form
by selecting the Tabulate command from the Data drop-down menu. You must first
freeze the display by selecting Freeze from the Options drop-down menu. A Tabulated
Data window resembling that shown in Figure 7-16 appears. This shows the acquisition
time and the value recorded. The figure in the % Max column expresses the measured
value as a percentage of the FSD. To display tabular data for another displayed signal,
simply click the name of the signal (for example BBAB10-1000Hz_4) from the list of
names appearing at the bottom of the Machine Outputs window.

If there are many points stored for a machine, the tabulated display can take a long time.
To reduce the waiting time, define a lower value for the Max Data Points field on the
General Info tab of the Machine window. See 5.3 Managing machines.

• The Zoom drop-down menu enables you to reset the horizontal and vertical axes of the
strip chart to their default values. This is useful if these values have been changed by
sizing, repositioning and zooming (see 7.3.3 Sizing, repositioning and zooming). 
Furthermore, the Zoom command is useful when you have a large number of points
stored for a machine. In this case the tabulated display can take an appreciable length
of time. Using Zoom restricts the area to be tabulated to the values of interest, and so
requires less time.

Figure 7-14: Drop-down menus for strip charts (in Machine Outputs window)
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• In the Options drop-down menu, the Freeze command allows the currently displayed
strip charts to be frozen. This operation is necessary before displaying data in tabular
form (Figure 7-16), or performing sizing, repositioning and zooming operations (see
7.3.3 Sizing, repositioning and zooming). If the Freeze command is selected, the check
mark can be cleared and Freeze turned off by select this command again.

Figure 7-15: Typical strip chart display with the Data Summary window open

Figure 7-16: Tabulated Data Window
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7.3.3 Sizing, repositioning and zooming

You can size, reposition and zoom strip charts and trend charts using a combination of
keystrokes (SHIFT, CTRL) and mouse buttons. 

NOTE: For strip charts, you must first freeze the display by selecting Freeze from the
Options drop-down menu (see 7.3.2 Drop-down menu commands for strip
charts).

The keystroke operations are summarised below.

7.3.3.1 Chart sizing (CTRL + <MOUSE-Middle>) 

1- Hold down the CTRL key and the wheel (middle) mouse button (or both the left and right
buttons on a two-button mouse).

2- Drag the mouse pointer up the screen to reduce the size of the chart and drag it down
the screen to increase the size.

7.3.3.2 Chart repositioning (SHIFT + <MOUSE-Middle>) 

1- Hold down the SHIFT key and the wheel (middle) mouse button (or both the left and right
buttons on a two-button mouse) to attach the chart to the mouse pointer.

2- You can then drag the chart and drop it anywhere in the display window.

7.3.3.3 Scaled window zooming (SHIFT + <MOUSE-Left>)

1- Hold down the SHIFT key and drag the left mouse button to form a rectangular window
containing the area of interest on the chart. 

2- When you release the mouse button, the display is zoomed to the rectangle and the X-
and y- axis scales are refreshed. 

7.3.3.4 Unscaled window zooming (CTRL + <MOUSE-Left>) 

1- Hold down the CTRL key and drag the left mouse button to form a rectangular window
containing the area of interest on the chart. 

2- When you release the mouse button, the display is zoomed to the rectangle. However,
in this case the x-axis and y-axis scales are not refreshed. 

7.3.3.5 Reset (r)

1- Press the r key to reset the horizontal and vertical axes of the trend chart to their default
values.

This is the same as choosing the Reset command from the Zoom drop-down menu. 

NOTE: This operation is case-sensitive and does not work with the R key.
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8 DISPLAYING HISTORICAL DATA

8.1 Introduction

This chapter describes the Historic Trend Chart and Historic Trend Chart (Averages)
commands in the Machine drop-down menu (Figure 8-1). These commands enable historical
data (which has been previously acquired and stored in a database) to be displayed.

This provides an insight into the progression of measured values over a period of time (the
period covered can range from several days to several years, depending on how the user
sets up the acquisition parameters). The historical trend charts obtained in this way provide
a useful tool to help perform predictive maintenance of the machine being monitored.

For information on displaying data in real-time, see 7 Displaying data in real-time.

8.2 Displaying historical trend charts

8.2.1 Overview

To display historical trend charts:

1- Use the mouse pointer to select a machine from the logical configuration tree.
The General Info tab appears by default in the main window (VM600 MPS2
Configuration Editor). (See 5.3.1 Configuring information at machine level.)

2- Select the Historic Trend Chart command from the Machine drop-down menu.
The Trend Chart Point Selection window appears (Figure 8-2). All output points for which
data exists are listed in the Associated Outputs column.

3- Highlight with the mouse pointer the points you want to chart, then transfer them to the
Display Points column using the > button (select more than one using SHIFT+click for
continguous points or CTRL+click for non-continguous points). Alternatively, you can
transfer all points using the >> button.

4- Click the Display button to obtain the Historic Trend Chart window (Figure 8-3).

The drop-down menu commands enable charts to be printed and data to be displayed in
tabular form. See 8.2.2 Drop-down menu commands for trend charts for a description of all
the possibilities.

The horizontal and vertical axes of a historical trend chart are set by default but you can zoom
to areas of particular interest. This is described in 7.3.3 Sizing, repositioning and zooming.

Figure 8-1: Machine drop-down menu
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To use the cursor feature, click with the mouse pointer on the chart at the point of interest.
The Cursor Box window opens (Figure 8-4). The title bar of this window shows the date and
time of the acquisition. The signal values at that moment in time are shown in the window,
along with the measurement units, the rectifier function and the full-scale deflection (FSD)
value. The figure in the % Max column expresses the measured value as a percentage of the
FSD.

8.2.1.1 Updating the historical trend chart display

If you are displaying historical trend data while at the same time continuing to record data in

real-time, when new data is detected, the Refresh button ( ) under the Info menu becomes
enabled. Click this button to update the display with the current new data.

8.2.1.2 Changing plot background colour

You can select either a dark or light background colour for the display by clicking the Plot
Background Colour button ( ), under the File menu.

Figure 8-2: Trend Chart Point Selection window
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Figure 8-3: Typical Historic Trend Chart window 

Figure 8-4: Typical Historic Trend Chart window with the Cursor Box open
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8.2.2 Drop-down menu commands for trend charts

The HIstoric Trend Chart window contains six drop-down menus, as shown in Figure 8-5.

• To print the currently displayed trend charts, choose Print from the File menu.

• To obtain a data summary for each curve displayed, choose Data from the Info menu.

A Data Summary window resembling that shown in Figure 8-6 appears. The Start Date,
End Date and No. of Points relate only to the part of the curve displayed. To display a
data summary for another signal, simply click the name of the signal from the list of
names appearing at the bottom of the Historic Trend Chart window.

• To display the Display Setup dialog box, choose the Display command from the Setup
drop-down menu. 

From this box you can choose to display the alarm levels on the Historic Trend Chart
(select the Alarms check box to do this). You can also display vertical and/or horizontal
grid lines on the chart by selecting the x-axis and/or y-axis check boxes, respectively.

• To specify the start and stop date and times of the data to display, select the Time Filter
command from the Setup menu. You can then choose the start and end of the time
interval to be displayed, from a standard Windows Date/Time control.

• You can present the trend charts displayed in the Historic Trend Chart window in tabular
form by selecting the Tabulate command from the Data drop-down menu. A Tabulated
Data Window resembling that shown in Figure 8-7 appears. This shows the acquisition
time and the value recorded. The figure in the % Max column expresses the measured
value as a percentage of the FSD. To display tabular data for another displayed signal,
simply click the name of the signal from the list of names appearing at the bottom of the
HIstoric Trend Chart window.

• The Zoom drop-down menu allows you to reset the horizontal and vertical axes of the
strip chart to their default values. This is useful if these values have been changed by
sizing, repositioning and zooming (see 7.3.3 Sizing, repositioning and zooming).

• The Options drop-down menu is not operational for Trend Charts and Averages Trend
Charts.

Figure 8-5: Drop-down menus for historical trend charts (in Trend Chart window)
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Figure 8-6: Typical HIstoric Trend Chart window with the Data Summary window open

Figure 8-7: Typical Tabulated Data Window
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8.3 Displaying averages trend charts

8.3.1 Overview

The approach to displaying averages trend charts is very similar to that for normal trend
charts. See 8.2 Displaying historical trend charts for further information.

To display averages trend charts:

1- Use the mouse pointer to select a machine from the logical configuration tree.

The General Info tab appears by default in the main window (VM600 MPS2 Configuration
Editor). (See 5.3.1 Configuring information at machine level.)

2- Select the Historic Trend Chart (Averages) command from the Machine drop-down
menu. The Trend Chart (Averaging) Point Selection window appears (Figure 8-8).

All output points for which data exists are listed in the Associated Outputs column.

3- Highlight with the mouse pointer the points you want to chart, then transfer them to the
Display Points column using the > button (select more than one using SHIFT+click for
continguous points or CTRL+click for non-continguous points). Alternatively, you can
transfer all points using the >> button.

4- You can display one or more of the following curves: minimum values, maximum values
or averaged values.

Choose the curve(s) you want to display by selecting the Minimum Values, Maximum
Values or Average Values check boxes, as appropriate.

5- Click the Display button to obtain the HIstoric Trend Chart (Averages) window
(Figure 8-9).

The drop-down menu commands enable charts to be printed and data to be displayed in
tabular form. See 8.2.2 Drop-down menu commands for trend charts for a description of all
commands.

The horizontal and vertical axes of the trend chart are set by default, but you can zoom to
areas of particular interest. This is described in 7.3.3 Sizing, repositioning and zooming.

To use the cursor feature, click with the mouse pointer on the chart at the point of interest.
The Cursor Box window opens (Figure 8-10). The title bar of this window shows the date and
time of the (averaged) acquisition. The minimum and maximum values found for each signal
while calculating the average value are displayed in the Min and Max columns respectively.
The average value of the values considered is shown for each signal in the Avg column.
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Figure 8-8: Trend Chart (Averaging) Point Selection window

Figure 8-9: Typical window for a Historic Trend Chart (Averages)
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8.3.2 Further information

The window for a Historic Trend Chart (Averages) contains the same drop-down menus as
seen in Figure 8-5. 

The only difference to note is the aspect of the Tabulated Data Window obtained by selecting
the Tabulate command from the Data drop-down menu (see Figure 8-11). For a Historic
Trend Chart (Averages), the Start Date column shows the times at the middle of each group
of acquisitions (that is, if the average of n normal mode acquisitions is taken to put in the
Historic Trend Chart (Averages) database, the time corresponds to the time at which
acquisition number n/2 was taken). The Min and Max columns show the minimum and
maximum values found for the signal during each block of n acquisitions. The average value
of these n acquisitions is shown for each time interval in the Avg column.

To display tabular data for another displayed signal, simply click the name of the signal in the
list of names appearing at the bottom of the Historic Trend Chart (Averages) window.

Figure 8-10: Cursor Box for a Historic Trend Chart (Averages)

Figure 8-11: Typical Tabulated Data Window for a Historic Trend Chart (Averages)
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9 CUSTOMER SUPPORT

9.1 Contacting us

Meggitt Sensing Systems’ worldwide customer support network offers a range of support
including 9.2 Technical support and 9.3 Sales and repairs support. For customer support,
contact your local Meggitt Sensing Systems representative. Alternatively, contact our main
office:

Customer support

Meggitt SA

Route de Moncor 4

PO Box 1616

CH-1701 Fribourg

Switzerland

Telephone: +41 (0)26 407 11 11

Email: energysupport@ch.meggitt.com

Web: www.meggittsensingsystems.com

9.2 Technical support

Meggitt Sensing Systems’ technical support team provide both pre-sales and post-sales
technical support, including:

1- General advice

2- Technical advice

3- Troubleshooting

4- Site visits.

NOTE: For further information, contact Meggitt Sensing Systems (see 9.1 Contacting us).

9.3 Sales and repairs support

Meggitt Sensing Systems’ sales team provide both pre-sales and post-sales support,
including advice on:

1- New products

2- Spare parts

3- Repairs.

NOTE: If a product has to be returned for repairs, then it should be accompanied by a
completed Failure report form, included on page 9-3.
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9.4 Customer feedback

As part of our continuing commitment to improving customer service, we warmly welcome
your opinions. To provide feedback, complete the Customer feedback form on page 9-5 and
return it Meggitt Sensing Systems’ main office (see 9.1 Contacting us).
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FAILURE REPORT FORM

If the product has to be returned to Meggitt Sensing Systems for repairs, then:

1- Complete this failure report form.

2- Attach a photocopy of this report to the faulty unit and retain the original copy for your records.

3- Send the product together with the attached failure report form to Meggitt SA by registered post.

NOTE: Please provide as much information as possible in order to assist fault diagnosis.

NOTE: A failure report must be sent with each faulty product.

Contact details: 

Name Job title 

Company Email 

Address 

Country Post code 

Telephone Fax 

Signature Date 

Product details:

Product type: 

Serial number (S/N): Part number (P/N): 

Meggitt SA order number: 

Date of purchase: Site where installed: 

Is the failure (put an ⌧ where appropriate):

� Continuous? � Intermittent? � Temperature dependent?

Description of failure:

(Continue overleaf)
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(Continue on a separate sheet if necessary)
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.

    

CUSTOMER FEEDBACK FORM

Title of manual:

VM600 MPS2 Configuration Software for Machinery Protection Systems

Reference: MAMPS2-SW/E Version: Edition 8 Date of issue: June 2015

Customer contact details:

Name Job title 

Company Email 

Address 

Signature Date 

General feedback:

Please answer the following questions: 

• Is the document well organised? Yes No 

• Is the information technically accurate? Yes No 

• Is more technical detail required? Yes No 

• Are the instructions clear and complete? Yes No 

• Are the descriptions easy to understand? Yes No 

• Are the examples and diagrams/photographs helpful? Yes No 

• Are there enough examples and diagrams/photographs? Yes No 

• Is the style/wording easy to read? Yes No 

• Is any information not included? (please list in “additional feedback” below) Yes No 

Additional feedback: 

(Continue overleaf)
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