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Installing the PH Bin Label Generator 
Users install the application by navigating to: 
 
www.parkerbinlabels.com 
 

 

Install button – click to install the application. 

 
 
When the user clicks on the ‘Install’ button, the user is prompted to install the application 
through a series of security prompts which identify the application and publisher. The 
user installs the application and the application is launched. 
 
Auto update feature: Once installed, a check is performed to verify that the version of 
the application being launched is the latest version. Each time the user opens the 
program, the same check is performed.  
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http://apps.parker.com/divapps/tfd/blg2_installation/publish.htm


Obtaining Application Updates 
If there is a newer version of the application available, the user is prompted to download 
and install the update or skip the update until the next time the application is launched. 
As the updates are downloaded and installed, a progress bar displays the amount 
downloaded and the amount remaining. 
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Viewing the Update Notes 
Users can view the Software Udates Notes – known as ‘Release Notes’.  This allows 
users to see what portions of the application have been changed since the previous 
software release, after each update they perform. Users can also view the Data Release 
Notes which outline the primary changes to the data since the previous data update. The 
Release Notes viewer is available from the Help menu. 

 
Choose Software Release Notes from the Help menu to view the Release Notes 
pertaining to the current software version installed. 
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Installing the Data and Images 
Initially, the application does not have any data to view and the following screen is 
displayed: 

 
The user clicks the ‘Other Options’ button to install a new division, or if the dataset 
becomes corrupt, to re-install an existing division. After clicking this button, the 
following screen is displayed: 
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Next, the user selects a division from the list displayed and clicks the ‘Begin Download’ 
button, which is disabled until a division is selected to begin downloading the data and 
images from the hosting server. 

 
The download process can take a few minutes, even with a high-speed connection to the 
Internet, due to the volume of data and images being downloaded and verified. A 
progress bar at the bottom of the screen shows the progress of this step. It may take a 
minute to display the progress bar. 
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Once the download process is completed, the ‘Begin Install’ button is enabled and the 
user clicks this button to actually install the data and images and make them available to 
the user and application.  

 
As with the download process, a progress bar at the bottom of the screen indicates the 
application’s progress towards completing this step.  
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When this step is completed, the application closes this screen and returns to the ‘Select 
Startup Division’ screen with the newly installed division listed:  

 
Select the newly installed division and click ‘OK’ to load the associated parts data and 
proceed to the main program screen. 
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Running the Program
The program is launched from the user’s Start menu. Within the ‘All Programs’ group, 
users should look for ‘Parker Hannifin’ →  ‘Bin Label Generator’, as shown below: 

 
Once the application is launched, the Division Selection screen is displayed, showing the 
divisions currently installed. 

 

 

Other Options button – click to install a new 
division, or to re-install an existing division. 

OK button – click to load the selected division. 

 

The user selects a division or clicks on the ‘Other Options’ button to install a new 
division, or re-install an existing division, should an existing division’s data become 
corrupt at some point. If the division the user wants access to is listed in the list of 
existing divisions, the user selects it and clicks the ‘OK’ button. After a division has been 
installed or updated, or the user chooses an existing division to load and clicks the ‘OK’ 
button, the parts data for that division is loaded and the main application screen is 
displayed.  
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Periodically, updates to a division’s data and images are published to the Parker server 
hosting the application and data. When the program loads the data of a selected division, 
the software looks to the server to see if the local copy is the latest available version. 
When the program detects that a newer version of the data is available, the user is 
prompted to download and install this data, or be reminded of the update the next time 
they access that division’s program. 

 

If the user clicks the Yes button, then the Division Updater screen is displayed and the 
division is selected for the user. The user can click the ‘Begin Download’ button to start 
the download.  

 
Detailed instructions for the data and images update process can be found in the Installing 
Data and Image Updates section of this document.
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Main Application Screen 
From the application’s main screen, the user can create, save and open print lists saved 
during previous selections. Users navigate the parts listing tree control on the left side of 
the screen in the Part Families and Configurations box to find the items desired for labels.  
Product families are shown by default, but the “+” sign next to the family can be clicked 
to show the configuration and further the “+” next to the configuration to show the part 
numbers.  Users create print lists by dragging part numbers, part configurations and/or 
part families from the parts tree to the Parts Selected for Label Printing box in the upper 
right-hand portion of the screen.  

 

Other functionality available from this screen includes configuration of print settings and 
ability to select predefined label templates.  
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Saving Print Lists 
Users create print lists by dragging part number, configuration or family items from the 
‘Parts Families and Configurations’ box to the ‘Parts Selected for Label Printing’ box. 
The new print list is edited to include Alternate Part Numbers if applicable and then users 
can save the edited print list to reuse at a later date without needing to re-create the list. 

Users save the edited print lists by clicking the disk button  on the toolbar, clicking the 
‘Save List’ button below the print list, or by clicking the ‘File’ → ‘Save Set’ menu item 
from the main menu. When saving a print list, a ‘Save As’ dialogue is displayed to allow 
the user to select a location and enter a file name to use for the parker print list file. 
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Opening Print Lists and Importing Excel Files 
 

Users open saved print lists by clicking the ‘Open List’ button below the print list, or by 
clicking the ‘File’ →  ‘Open Set’ menu item from the main menu. When opening a print 
list, an ‘Open File’ dialogue is displayed to allow users to select the file being opened. 
Valid print list files have a file extension of ‘.ppl’ which stands for Parker Print List, or 
‘.xls’ for Microsoft Excel files.  

 
Note: Excel functionality is for legacy use only with print lists created with previous 
versions of this software. PPL versions contain additional data such as Alternate Part 
Numbers, Descriptions, etc. and are saved as ASCII formatted text files.  

Once the Print List has been opened, users can edit them to enter or edit Alternate Part 
Numbers, and then save them as described in the Saving Print Lists section of this 
document. 
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When importing excel files, they must adhere to some basic formatting requirements. No 
column headings are allowed1 and the spreadsheet data is to be arranged as follows: 

• Parker Part Numbers are always included in the first column of the first 
worksheet. 

• Alternate Part Numbers are always included in the second column. Leave this 
column blank if there are no Alternate Part Numbers. 

• Additional columns are always ignored. 
1 If column headings are included in the first Row of the spreadsheet, the heading for the first 
column is considered to be a part number and will most likely be included in the list of import 
errors, described in this section. 

Since it will only recognize parts that are in that division’s database, if one or more part 
numbers are not found in the database, a window is opened containing a list of these part 
numbers. This list can be saved or printed for later use in determining the cause of the 
error. 
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Adding or Assigning Alternate Part Numbers 
Users can enter alternate part numbers (such as customer part numbers) for individual 
parts by double-clicking the part number and entering the text in the entry box that 
appears next to the selected part number.  
 

 

Alternate Part Number entry box 
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Users can also select multiple parts and then right-click on the selected part numbers and 
choose ‘Assign Alternate Part Numbers’ from the resulting context menu 
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The Alternate Part Number Editor is similar to the list control in the main screen in that 
alternate part numbers are entered by double-clicking part numbers and entering the 
alternate part numbers in the entry boxes. Changes are not saved to the main screen’s 
print list until the user clicks the ‘Save’ button, however, and all changes are discarded if 
the user clicks the ‘Cancel’ button. 
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Barcode Options 
Users have a variety of barcode printing options available. Bar code printing options 
include: 

• ‘No Bar code’, 
• ‘Parker Part Number’, 
• ‘Alternate Part Number’ and 
• ‘Alternate Part Number (else Parker PN)’.  

 
The no bar code option simply means that the printed labels will not include a bar code.  

The ‘Parker Part Number’ option means that the part number assigned by Parker 
Hannifin will be used to encode the bar code printed on the label.  

The ‘Alternate Part Number’ option will only use the assigned alternate part numbers to 
generate bar codes. If there is no Alternate Part Number assigned, no bar code will be 
printed.  

Choosing the fourth item, ‘Alternate Part Number (else Parker PN)’, will use the alternate 
part number to generate the printed bar code when available, but if no Alternate Part 
Number has been assigned, the part number assigned by Parker Hannifin will be used to 
generate the printed bar code. 
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Label Templates 
There are three predefined label templates for use with this application.  

They include: 

• Avery 8160 (3 columns x 10 rows),  
• Avery 8163 (2 columns x 5 rows) and  
• Avery L7158 (3 columns x 10 rows, European Standard) 

 
Users use these predefined settings to generate parts labels. When printing to the Avery 
8160 or Avery L7158 formats, assigned Alternate Part Numbers will always replace the 
Part Description on the printed label if the bar code printing option is set to anything 
other than ‘No Bar Code’. 
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Distributor Logos 
Users can include their own logos on printed bin labels. This option is disabled until a 
distributor logo has been defined by using the ‘Set Distributor Logo’ utility located as a 
menu item under the ‘File’ menu. 

 
When selecting a logo image file, users browse to the location of the image file, select it 
and choose ‘Open’. Distributor logo images must be in a JPEG format with a file 
extension of .jpg. 
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To include the configured distributor logo on the printed labels, the user checks the 
‘Show Distributor Logo’ checkbox. 

 

Preview and Print Labels 
The user clicks the ‘Preview Labels’ button to display a print preview of the selected 
labels and send a print request to a printer connected to the user’s Windows desktop. 
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Print preview of Avery 8160 label sheets: 
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Print previews of Avery 8163 label sheets: 
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Print previews of Avery L7158 label sheets: 
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Obtaining Data and Image Updates 
Over time, each division may add new part numbers or entire product lines. To ensure 
that the user always has the most current and accurate data available to use in generating 
bin labels, the application automatically looks for updated data on the server where the 
master parts data and images are stored. Users are prompted when updates are available 
as they load a division at startup or switch divisions after the program has started 
(discussed in the next section of this document). Users can also refresh or update their 
data manually by choosing the E-Download menu option under the File menu: 
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The procedures for downloading and installing updated parts data and images is the same 
as it is for initially loading the data, described in the Installing the Data and Images 
section of this document. The only difference is that users select a division from the list 
of divisions currently installed on their system.  

Users can also download and install data and images for other divisions by selecting the 
‘Show a list of Divisions not yet installed on this system’ radio button, selecting the 
division from the displayed list of divisions not installed and following the same 
procedures used for updating data already installed. 

 

 
 
Please note that parts data and images can be updated through either the division selector 
screen that displays the divisions already installed when starting the program, or by using 
the E-Download procedures discussed above. 
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Switching Between Installed Divisions 
When users have multiple divisions installed on a single system, switching between 
divisions is accomplished by choosing the appropriate division from the ‘Division’ menu.  
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Installing Additional Divisions 
If a division is desired that is not present in the list, users can choose to download and 
install that division’s parts data and images by choosing the ‘Install another Division’ 
menu item under the list of installed divisions. The procedures for loading another 
division are the same as those for initially obtaining the parts data and images, described 
in the Installing the Data and Images section of this document. 
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